Amicus 18 FTDI driver on W10?

Closed Thread
Results 1 to 23 of 23

Hybrid View

  1. #1
    Join Date
    Oct 2005

    Default Amicus 18 FTDI driver on W10?

    So I've got myself a new PC (with Window 10) and I'm slowly setting everything up.

    I'm now at the point where I need to get the Amicus 18 bootloader to work. Plugging an Amicus 18 board in to the PC makes it show up in the device manager but no driver is installed. So I installed Proton IDE ( with Proton compiler but no dice.

    I tried to manually install the driver by pointing the driver wizard to the Amicus18 USB Driver folder within the ProtonIDE installation but it complains about a missing hash value.

    Tried downloading the generic FTDI CDM driver (2.12.26) and pointed it to that but no go.

    I've Googled for a while and found an [urll]archived thread[/url] on the Proton forum where someone apparently provides a solution but I can't seem to find the attachment anywhere.

    So, anyone knows how to get the Amicus Loader to work on Win10? I use that board extensively when trying and debugging quick things when helping out her on the forum, I'd hate to see it not working on W10.

    I'd appreciate any pointers, thank you!


  2. #2
    Join Date
    Oct 2005

    Default Re: Amicus 18 FTDI driver on W10?

    BTW, plugging in a generic USB to UART board based on the FTDI FT232RL (same chip as on the Amicus 18) works just fine.

  3. #3
    Join Date
    Oct 2005

    Default Re: Amicus 18 FTDI driver on W10?

    More info:
    On the Proton forum I found a thread with links showing how to install unsigned driver so I followed that and was able to install the Amicus 18 serial port driver (which again is nothing other than the standard FTDI driver as far as I understand) and it shows up correctly in device manager. But when rebooting into normal mode and plugging in the Amicus 18 it again refuses to use the driver.

    For reference, here's the thread on the Proton forum.


  4. #4
    Join Date
    Sep 2009

    Default Re: Amicus 18 FTDI driver on W10?

    That is new "state of art" way to protect user from malicious drivers. Or to be honest, very good way to get more money. Because certificates have expiration date. You know, after some period drivers turn bad....
    And you pay about 200-500$ per year to maintain drivers signed and to redistribute new signed driver every 1 to 3 years.
    You have option to get 32bit version, and then it shouldn't disable unsigned drivers, go back to win 7, or pay to sign driver...
    Even if original driver is signed, they probably changed PID and VID for Amicus, so that render driver useless.

    There is one more option, but probably wont work.
    You can try to manually force FTDI driver to Amicus.
    1. Uninstall all drivers for Amicus.
    2. When you plugin USB cancel automatic search.
    3. Go to device meager right click properties, go to driver tab, click update driver
    4. Let me browse option, Then select from list, or what ever is called on win10
    5. Then click to have disk, select FTDI signed drives files.
    6. Click what ever is needed to install it. You should get some errors that driver isn't compatible, etc...
    This you may expect with all drivers stored on disc. So you need always to have new signed driver. Or at least every couple years.
    I have this issue with microchip drivers for my devices. I have CDC on couple devices and just changer PID and VID to match with PID and VID in device, and that makes driver unsigned. And you also need to pay VID to USB...
    Also there is some changes in CE certification for EU. So it seems that small manufacturers have no chance....
    Hope that this help you.

  5. #5
    Join Date
    Aug 2011

    Default Re: Amicus 18 FTDI driver on W10?

    Even though the chip on the amicus18 board is an FT232RL, the USB PID has been changed so that it appears as an "Amicus18 Serial Port" (USB\VID_0403&PID_AC75). Once that was done it required the use of a modified INF driver file.

    There is (at least was) a utility on the FTDI site called FT_PROG that would let you change the PID back to the standard FTDI PID for the FT232RL, and that would let you use the standard FTDI driver. I don't know if there are any issues with that (like a loader program looking for the old AC75 PID), but hardware-wise that should work fine.

    I've only used FT_PROG on win7 so I have no idea if/how it works on win10.

  6. #6
    Join Date
    Mar 2003
    Commerce Michigan USA

    Default Re: Amicus 18 FTDI driver on W10?

    Yes, In fact I recently purchased a few Amicus18 boards for a development program. I switched out the processor for an 18F26K22 and used the FT_PROG program from FTDI to set the PID to a default state. This however can only be done after the board is found and connected by the operating system which requires the Amicus software to be loaded on the computer you are using to do the reprogramming. I then use the PBP3 with the MCSPX boot loader for all program development. Works a treat...
    Dave Purola,

  7. #7
    Join Date
    Apr 2003
    Cambridge - UK

    Default Re: Amicus 18 FTDI driver on W10?

    Taken from the Proton Forum -----
    Henrik you did not respond to the registration email sent from the Proton forum, hence your inability to download or post. I could not activate your account manually because I could not locate your chosen user name on the Pron forum

    So i've copied the post here, it may help you and others.

    Tips for Programming Amicus 18 on Windows 10

    Hi All,

    I recently wanted to do some work using the Amicus 18, and after a good number of retries and searching through various Forums, I can say I have managed to reliably succeed:-). Whilst I have not had to do anything NOT covered in various posts, I felt it might help someone else migrating to Windows 10, if all the steps I have had to follow are in a single consolidated place, So here goes...

    1. Install the latest Proton Basic Compiler Suite found on the Proton Basic Compiler Website - I installed Version
    2. Download and install the most recent "Amicus18_Loader" (attached) and unzip into a known location.
    3. As per DaveS' instruction, rename the old "Amicus18_Loader.exe" to "Amicus18_LoaderOLD.exe" and copy the just unpacked new "Amicus18_Loader.exe" into the same location as the OLD version. On my 64bit version of Windows 10 the location is "C:\Program Files (x86)\ProtonIDE\Plugin\Amicus18_Loader\"
    4. Connect your Amicus18 board to a USB port - ignore any errors - it won't load correctly - yet:-)
    5. Get ready to reboot your Windows 10 system - ie. close all running programs - We need to Disable Unsigned Driver Checking...
    If you have previously done this, do it again:-) It seems some Windows updates possibly reinstate signed driver checking, so it doesn't harm to simply do it again.
    6. Right Click on the Windows "Start" icon and select "Settings"
    7. Click on "Update and Security"
    8. Select "Recovery", and then click on "Restart Now" under "Advanced Startup"
    9. The system will start the restart process by presenting a Blue screen with three options - "Continue to Windows 10", "Troubleshoot" or "Turn Off Computer"
    10. Click on "Troubleshoot", then "Advanced", then "StartUp Settings", then "Restart" .The system will reboot and present you with a second Blue screen this time with a list of options. Select Option 7 with the Keyboard to disable Unsigned Driver Checking.
    11. The system will proceed with the familiar reboot "Windows".
    12. Once rebooted there are still a few steps to complete - the first is to install the correct drivers for the FTDI chip.
    13. Locate the directory "C:\Program Files (x86)\ProtonIDE\Amicus18 USB Driver\" and find two files - "ftdiport.inf" and "ftdibus.inf".
    14. In turn right click on each of the driver files and select "Install". After each selection you should be presented with a "warning" about unsigned driver installation - select the second option to install.
    15. After both have been installed, it's a good idea to right click on the "Start" icon and select "Device Manager". You should now see "Amicus18 Serial Port (COMx)" under "Ports", with NO error indications. Right click on it and select "Properties" - it should show that the device is working properly:-)
    16. The final step is to Start the Proton Compiler, and select "View" from the top toolbar.
    17. Select "Compile and Program Options" and then select "Programmer"
    18. In the "Default Programmer" drop down, ensure "Amicus18 Loader" is selected
    19. Click "OK" and you should be good to go:-)

    Hope this helps someone:-)

    Lester - Forum Administrator

  8. #8
    Join Date
    Oct 2005

    Default Re: Amicus 18 FTDI driver on W10?

    Thank you Lester!
    I don't know why I missed responding to the registration email or if it ended up somewhere it shouldn't at my end.

    Anyway, I just did what Norm described and it seems to have worked perfectly. I now have a working AMICUS18 setup that can be bootloaded directly from within MicrocodeStudio. I have no shortage of development boards (mostly MikroE stuff) and they're all great but none are as fast and "transparent" to use as the AMICUS18 setup. Small programs compiles and downloads in a second while with the other "systems" I have to jump between application, reload .hex file, click buttons, (since MikroE's bootloaders doesn't provide a command line interface), press buttons on the board (to get into bootload mode) or use the PICKit3 which, for small programs, is MUCH slower than bootloading.

    So, thank you Lester for posting the information and special .exe (and for the AMICUS platform) and thank you Norm for providing such detailed instructions on how to get it going on W10! Much appreciated!


Similar Threads

  1. Amicus shields
    By Bruce in forum PBP & Amicus18
    Replies: 33
    Last Post: - 30th July 2011, 22:06
  2. AMICUS 18 Section
    By charudatt in forum Forum Requests
    Replies: 26
    Last Post: - 17th July 2011, 10:03
  3. Amicus Name
    By Charles Linquis in forum PBP & Amicus18
    Replies: 12
    Last Post: - 31st May 2011, 05:01
  4. Amicus 18 Review
    By lester in forum General
    Replies: 0
    Last Post: - 10th June 2010, 07:58

Members who have read this thread : 2

You do not have permission to view the list of names.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts