So I've got myself a new PC (with Window 10) and I'm slowly setting everything up.

I'm now at the point where I need to get the Amicus 18 bootloader to work. Plugging an Amicus 18 board in to the PC makes it show up in the device manager but no driver is installed. So I installed Proton IDE ( with Proton compiler but no dice.

I tried to manually install the driver by pointing the driver wizard to the Amicus18 USB Driver folder within the ProtonIDE installation but it complains about a missing hash value.

Tried downloading the generic FTDI CDM driver (2.12.26) and pointed it to that but no go.

I've Googled for a while and found an [urllhttp://www.protonbasic.co.uk/archive/index.php/t-75562.html]archived thread[/url] on the Proton forum where someone apparently provides a solution but I can't seem to find the attachment anywhere.

So, anyone knows how to get the Amicus Loader to work on Win10? I use that board extensively when trying and debugging quick things when helping out her on the forum, I'd hate to see it not working on W10.

I'd appreciate any pointers, thank you!