Search Results - MEL PICBASIC Forum


Search:

Type: Posts; User: queenidog; Keyword(s):

Search: Search took 0.00 seconds.

  1. Replies
    15
    Views
    20,608

    Re: PicBasic Lookup command update: hardware problem

    I had tried everything to get RA6 and RA7 working and when they were not (by noting the lights connected to these pins were not lighting up) I started poking around first with my logic probe, and...
  2. Replies
    15
    Views
    20,608

    Re: PicBasic Lookup command

    Okay, one problem solved...now another. I'm using RA6 and RA7 and want to use the internal oscillator. I think I have to set bit 2 of CONFIG1 to 1 in order to select INTOSCIO.
    I tried config1=...
  3. Replies
    15
    Views
    20,608

    Re: PicBasic Lookup command

    I figured it out. Not having played with too many CPU/MPU/MCU that are multi purpose I was not aware that the port could be analog or digital
    Initializing Ansel to 0 fixed the problem. The code...
  4. Replies
    15
    Views
    20,608

    Re: PicBasic Lookup command

    Here is the "complete" code. This is a test area where I have all my equates and variable declarations for a bigger code, but I check little pieces at a time. The piece I'm checking now is the...
  5. Replies
    15
    Views
    20,608

    Re: PicBasic Lookup command

    Lolite is a byte.

    I looked at that...but I don't see anything wrong. Lolite is a byte, out is a byte and all the values are bytes.

    What am I missing?
  6. Replies
    15
    Views
    20,608

    PicBasic Lookup command

    I have a little snippet of code where I lookup a value and send it to PortA (Lolite=PortA) of my PIC16F887. Here is the code:
    For d = 0 To 7
    Lookup...
Results 1 to 6 of 6