Turn off "case-sensitive".

If you have MPLABX 5.35, the version of mpasmx should be 5.87... that's the last released version.
You should find it in the MPLABX install directory under the mpasmx...