View Full Version : Dreaded <target device ID 3FFF> - SOLVED

- 12th May 2023, 22:09
I asked this over at MeLabs; hopefully someone here knows the answer.

What I'm doing:
- I finally found my old U2 USB programmer so I thought I'd run some tests, I'm not going anywhere fast.
- using MeProg.exe:
- selecting PIC in dropdown list.
- keep getting that 3FFF error.


- Win 10-64bit.
- U2 USB programmer v4.67, firmware v6.5
- MeLabs 40-pin ZIF adapter and jumper cable (came bundled with programmer).
- PIC 16F877.


What I tried, always getting the same 3FFF error:
- the U2 programmer software/hardware at these up-to-date versions.
- the U2 programmer software/hardware at my settings from 15 years ago (U2 v4.32 FW v5.7).
- connected to blue SS USB port in front of desktop PC.
- connected to USB port at rear straight on motherboard.
- connected to self-powered USB hub.
- with "yet another" new PIC 16F877-20/P right out of my anti-static storage bag (I'm up to 6 of these 16F877 that don't respond).
- with 16F628, 18F4550 and 18F26K22.

"Out of ideas at this point"

- 12th May 2023, 23:47
I pull out an old circuit with a 18F44K22, connect my U2, check the Device ID, but I used the JUMPER THAT WAS ON THAT CIRCUIT ALREADY. The darn thing worked. I swap for one of my 16F877, program, swap it to my new test breadboard on the left, and instant heartbeat.


All these days going nowhere, it was the fracking cable that came with the U2 USB programmer. I still have the super-short cable that came with my U2 Serial Programmer, and that one works fine. It's just too damn short so I had made a 2 inch version.

So I pull out the meter and start checking continuity on the jumper. This is what it looks like. :O




- 13th May 2023, 11:24
I've never used a U2, but that doesn't seem to match up to what's on the website...

- 13th May 2023, 18:45
No kidding. :D

There's a serious short-circuit happening in those header terminals. I think the cable isn't perfectly aligned at the ends, and the contacts rubbed alongside two wires.

I tested the one I made and it's all one-pin-to-one-pin, same as with the ridiculously short cable I got with the U2 Serial programmer (when I first started), as expected from a flat header cable assembly.

I'm gonna open it up later just to look inside. I'm just happy I finally tracked the the source of ONE of my "recent" puzzles. :)