USBinit and USBservice


+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2005
    Location
    New Jersey
    Posts
    425

    Default USBinit and USBservice

    Why when I compile a program for an 18F4550 with MPASM and PBP, I keep getting an error that says "ERROR: Macro USBINIT? not found in macro file" and the same for USBSERVICE. Does anyone know how to solve this problem?

    Thanks,

    Chris

  2. #2
    Join Date
    Jul 2003
    Posts
    2,405

    Default

    You have a number of support files that need to be in the same directory as
    the file you're compiling. If these files aren't in the same directory, you'll get
    this error.
    Regards,

    -Bruce
    tech at rentron.com
    http://www.rentron.com

  3. #3
    Join Date
    Oct 2005
    Location
    New Jersey
    Posts
    425

    Default

    Bruce,

    Can you elaborate? I understand what you are saying but I don't know what to look for.

    Chris

  4. #4
    Join Date
    Jul 2003
    Posts
    2,405

    Default

    Hi Chris,

    Look in USB.TXT in your USB18 directory.

    You can also download EasyHID from http://www.mecanique.co.uk/products/usb/easyhid.html

    It will create all the required files for you & place them all in one directory.
    Regards,

    -Bruce
    tech at rentron.com
    http://www.rentron.com

  5. #5
    Join Date
    Oct 2005
    Location
    New Jersey
    Posts
    425

    Default

    I have those files but I still can't figure out why I am still getting this message. Any ideas?

  6. #6
    Join Date
    Jul 2003
    Posts
    2,405

    Default

    OK, but is the file you're trying to compile in the same sub directory as the
    USB support files?

    I can force this exact same error, but only if the file I'm compiling isn't in the
    same directory as the required USB include files.
    Regards,

    -Bruce
    tech at rentron.com
    http://www.rentron.com

Similar Threads

  1. PBPro error "Macro USBINIT? not found in macro file"
    By Bonxy in forum mel PIC BASIC Pro
    Replies: 2
    Last Post: - 4th October 2011, 10:06
  2. Easy HID Command -Response application
    By ptig185 in forum USB
    Replies: 25
    Last Post: - 22nd September 2010, 20:56
  3. Simple USB Comms Problem
    By awmt102 in forum mel PIC BASIC Pro
    Replies: 0
    Last Post: - 6th January 2010, 21:17
  4. Problem with enumeration and EasyHID
    By jizyjuice in forum USB
    Replies: 22
    Last Post: - 9th April 2007, 21:40
  5. PortA reset zero after USBINIT / Service ?
    By sirnoname in forum USB
    Replies: 4
    Last Post: - 1st December 2006, 16:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts