Compiler (PBP v2.50C) errors


+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Join Date
    Nov 2004
    Location
    Calabasas, CA
    Posts
    84

    Default Compiler (PBP v2.50C) errors

    Hi,

    Back after a few years off, using a new laptop & os, having lots of issues using a previously working program & PIC.

    (too many) Compiler (PBP v2.50C) errors found : Cannot open file (Include file C:\Program Files (x86)\Mecanique\PBP\pbppic14.lib (using PIC16C711)

    Also yesterday, My programmer (MELabs Programmer Beta ver 4.61.0) seems to go through the programming process without error, but the chip doesn't get programmed (blank). (using PIC16C711) - I Set Options to Default.

    Any suggestions will be greatly appreciated.
    James

  2. #2
    Join Date
    Feb 2013
    Posts
    795

    Default Re: Compiler (PBP v2.50C) errors

    Run as administrator....

  3. #3

    Default Re: Compiler (PBP v2.50C) errors

    I am now going through something similar. Out of the blue my PicStart Plus at the office won't program 16LF819. I also have another one there and I get the same error readings. However both program 8 pin and 28 pin chips without any problem. Yesterday I took the chips home with me to program them on my programmer. Same error messages. I now have come to the conclusion that the entire batch of chips is bad because I have some older 16LF819's at home that program without any problems.

  4. #4
    Join Date
    Apr 2014
    Location
    Northeast
    Posts
    437

    Default Re: Compiler (PBP v2.50C) errors

    To droptail; you reloaded your older version of PBP onto a newer PC. What version of MPLAB(X) are you using? If you just went to the Microchip site and downloaded the latest, you have MPLABX version 5.50. For PBP you need version 5.35 or older. This will certainly flub things up.

    To Peter; the fact that something simultaneously happened on 2 computers at 2 different locations is quite coincidental. If you have a new batch of PICs, that could explain the coincidence. If you had previously programmed one or more from that batch, then I suspect a Windows update may be the culprit.

  5. #5
    Join Date
    Nov 2003
    Location
    Greece
    Posts
    3,176

    Default Re: Compiler (PBP v2.50C) errors

    With the 819's I had bad times and I could never find what really was the cause of the problems. Some time it was the bad connection of the probe, other the software (a reboot correct it..!) but never on other chips such strange behavior happend.

    Recently, although on some of my pcbs there are still used these oldies, I do not face such problems. Gear the same. Go figure...

    Ioannis

  6. #6
    Join Date
    Apr 2014
    Location
    Northeast
    Posts
    437

    Default Re: Compiler (PBP v2.50C) errors

    I'm working on a project that just requires a 40 pin PIC; nothing fancy, any 40 pin will do. I have an old batch of PIC18F26K22's from a project years ago; brand new, bought from Digi-Key, still in the shipping tube. I found the pins couldn't deliver clean digital outputs; a LOW still had almost a volt, while a HIGH was barely over 4 volts (at 5 volts VDD). Switched to a K40 and everything switched clean. Maybe older stock somehow has issues, and with the electronics shortages, I've been told sellers are dusting off older Revision parts and selling them. The possibilities are endless, all things considered.

  7. #7
    Join Date
    Nov 2003
    Location
    Greece
    Posts
    3,176

    Default Re: Compiler (PBP v2.50C) errors

    That is really strange. Because the chips are C-MOS, static can do damage if not handled right.

    Do all the chips in the tube have the same behavior?

    Ioannis

  8. #8
    Join Date
    Feb 2013
    Posts
    795

    Default Re: Compiler (PBP v2.50C) errors

    I had exactly same issue with voltages and found out that reason was ADCON not configured properly

  9. #9
    Join Date
    Apr 2014
    Location
    Northeast
    Posts
    437

    Default Re: Compiler (PBP v2.50C) errors

    Ioannis: Don't know, switched to the K40 and didn't bother sorting through them.

    CuriousOne: I make it a habbit to spell out ALL Registers for PORTs, ADC, and any other peripheral I use. Between the ANSEL, TRIS, and ADCON Registers, I don't think I missed anything applicable to Analog. Furthermore, it was ALL the I/O pins (and I am using most of the pins for Digital).

Similar Threads

  1. Trying to resolving 6 Compiler Errors
    By Ramius in forum General
    Replies: 7
    Last Post: - 11th April 2011, 03:42
  2. pbp 2.50c vs ntvdm.exe
    By Freman in forum mel PIC BASIC Pro
    Replies: 5
    Last Post: - 28th July 2009, 06:33
  3. Replies: 3
    Last Post: - 1st July 2008, 22:07
  4. Are these errors in the PBP manual?
    By websmith in forum mel PIC BASIC Pro
    Replies: 3
    Last Post: - 30th November 2006, 09:22
  5. Compiler Errors
    By Conspiracy Bro in forum mel PIC BASIC Pro
    Replies: 3
    Last Post: - 1st November 2004, 17:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts