Problems programming a 10F206 PIC using the Melabs U2 USB Programmer


+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2004
    Location
    UK-Midlands
    Posts
    81

    Default Problems programming a 10F206 PIC using the Melabs U2 USB Programmer

    Hi All,

    Having programmed 12F, 16F and 18F parts over many years with Melabs USB programmer with no problems I am struggling trying to program a 10F206 chip.

    I get 2 error messages when trying to program the chip. "Calibration programming error" followed by "Erase Failed".
    If I keep trying to program it once in a blue moon it will program correctly.

    Here is what I have tried so far:

    The chip is not in a circuit but stand alone.
    Tried 2 chips both are showing this problem
    Have tried both my home setup and my work setup. Both identical programmers and each PC running Windows 10.
    The wiring to the PIC has been checked by others.


    Both programmers are Melabs U2 USB programmer version 4.66
    I have exhausted all my ideas and appreciate any clue as to the problem?


    Many thanks,
    Bob

  2. #2
    Join Date
    May 2013
    Location
    australia
    Posts
    1,612

    Default Re: Problems programming a 10F206 PIC using the Melabs U2 USB Programmer

    sounds like you have erased the chips osccal value.
    search the forum for osccal and how to recover the value.
    This is more entertaining than Free to Air TV

  3. #3
    Join Date
    Apr 2014
    Location
    Northeast
    Posts
    313

    Default Re: Problems programming a 10F206 PIC using the Melabs U2 USB Programmer

    Referencing Figure 1 (page 2) of the PIC10F200/202/204/206 data sheet, VDD is pin 5 and VSS is pin 2. How did you physically mount a PIC10F206 into a ME Labs U2 Programmer?!?

    You are going to have to run jumper wires to a PICkit3/4 to program this micro beast (or run them to your U2).

  4. #4
    Join Date
    Nov 2003
    Location
    Greece
    Posts
    2,909

    Default Re: Problems programming a 10F206 PIC using the Melabs U2 USB Programmer

    One problem seems to be the calibration that might be lost. On my programmer (Elnec Pikprog+) there is a checkbox to preserve the calibration before erasing the chip. Please check that on yours.

    The second problem seems to be related to a bad contact of the pins, wires or whatever you use to physically connect the chip to the programmer.

    Ioannis

Similar Threads

  1. Replies: 0
    Last Post: - 27th January 2012, 18:04
  2. problem with melabs usb programmer
    By mjmccarron in forum General
    Replies: 6
    Last Post: - 3rd December 2011, 06:29
  3. 18F4431 and Melabs USB programmer ?
    By AndrewC in forum General
    Replies: 14
    Last Post: - 27th March 2009, 05:20
  4. Melabs U2 USB programmer
    By Ron Marcus in forum General
    Replies: 2
    Last Post: - 24th April 2008, 19:03
  5. Melabs USB Programmer
    By tmurph in forum General
    Replies: 1
    Last Post: - 25th December 2005, 03:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts