+ Reply to Thread
Results 1 to 3 of 3

Thread: Mpasmx

  1. #1
    Join Date
    Dec 2014
    Posts
    11

    Default Mpasmx

    I've been using PBP 3.0 gold, MPASMX and MCSP for the last few months without any problems. I decided to update MPLAB to version 4.1 and I loaded XC8 C compiler. Now when I try to compile something with PBP 3.0 and MCSP I get an error "unable to execute MPASMX." in MCSP. I've manually pointed MCSP to MPASMX but to no avail. Any help would be appreciated.

  2. #2
    Join Date
    May 2013
    Location
    australia
    Posts
    1,716

    Default Re: Mpasmx

    welcome to the Death Spiral of legacy software
    I would go back to an earlier version of mplabx , [3.55 works ok]
    get pbp working again . and then try 4.1 again , don't remove 3.55 though.
    usually mplabx allows multiple versions to coexist , I have not tried 4.1

    ps
    PBP_MPASM_Connector.exe you did try this ?
    its in you pbp/ MPASM-MPLAB_SETUP folder
    Last edited by richard; - 24th October 2017 at 23:25.
    This is more entertaining than Free to Air TV

  3. #3
    Join Date
    Jun 2016
    Posts
    66

    Default Re: Mpasmx

    ps
    PBP_MPASM_Connector.exe you did try this ?
    its in you pbp/ MPASM-MPLAB_SETUP folder
    After a long time I did try to compile a program getting the same error (I have delated many unused folders, to clean the pc and I should have daleted also MPASMX reference) . Connector.exe did solve the problem!

    Thank you Richard.

    Alberto

Members who have read this thread : 12

You do not have permission to view the list of names.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts