ENC28J60 SPI Not Working

+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2007
    Mansfield, UK

    Default ENC28J60 SPI Not Working

    Hi, Over the past few days I've been messing with an ENC28J60 from Microchip. I've connected it up with what I believe to be all the correct external components and I've connected the SPI interface to a PIC. The chip links up with my switch correctly but for some reason the chip doesn't seem to react to anything I send it over SPI.

    I've tried a simple program on the PIC that accepts serial data from a PC and forwards it to the ENC, I've tried sending commands directly from the PIC and my final effort was to bitbang data to it. I even tried adding LEDs to all the pins involved and slowing it right down and I can confirm that the pins match the SPI input timing (Figure 4-1) as defined in the datasheet exactly. I also tried LEDs while using the PICs SPI and they all flashed quickly proving that the PICs SPI was functioning.

    So far I can't make the ENC do anything. I've tried reading registers which always returns a blank reply and I've tried writing to PHY registers to make the LED outputs react differently and even a simple reset command. None have any effect on either of the 2 chips I've been testing with.

    I'm completely out of ideas now. I hope someone can help me.

    ENC28J60 Datasheet

  2. #2
    Join Date
    Apr 2014

    Default Re: ENC28J60 SPI Not Working


    Still have the sources????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts