Assembler problem


+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2005
    Location
    Campbell, CA
    Posts
    1,107

    Default Assembler problem

    I'm having a strange problem when using PBP on my new laptop. I'm away from home now, and don't have access to all my resources.

    I can compile using PBP (3.x) just fine.

    When I try to use the -n option for PBPL, the compile goes OK, but when it gets to the assembler I get the following:

    Name:  Screen Print.jpg
Views: 281
Size:  416.9 KB


    What is setup improperly on my laptop?
    Charles Linquist

  2. #2
    Join Date
    Aug 2006
    Location
    Look, behind you.
    Posts
    2,818


    Did you find this post helpful? Yes | No

    Default Re: Assembler problem

    Hi Charles,
    I hope I understood the question . . . In MCS Click View, click compile & program options, in there the first check box should be checked . . . Use compiler long words. HTH
    JS
    If you do not believe in MAGIC, Consider how currency has value simply by printing it, and is then traded for real assets.
    .
    Gold is the money of kings, silver is the money of gentlemen, barter is the money of peasants - but debt is the money of slaves
    .
    There simply is no "Happy Spam" If you do it you will disappear from this forum.

  3. #3
    Join Date
    Jul 2003
    Location
    Colorado Springs
    Posts
    4,959


    Did you find this post helpful? Yes | No

    Default Re: Assembler problem

    Scroll down through the list of errors.
    Look for one that says "WARNING: Unable to open INCLUDE file ..."

    I'm guessing you don't have DT_INT-18 on that computer.
    http://darreltaylor.com/DT_INTS-18/home.html

    Or, post the complete list of errors.
    Last edited by Darrel Taylor; - 26th January 2014 at 19:03.
    DT

  4. #4
    Join Date
    Jul 2003
    Location
    Colorado Springs
    Posts
    4,959


    Did you find this post helpful? Yes | No

    Default Re: Assembler problem

    Tried it here without DT_INTS and it gives the warnings at the compiler level, not the ASM.

    So you'll need to post the complete error list.
    DT

Similar Threads

  1. Assembler problem
    By om3bc in forum mel PIC BASIC Pro
    Replies: 4
    Last Post: - 25th March 2008, 19:12
  2. which Assembler
    By debutpic in forum mel PIC BASIC Pro
    Replies: 2
    Last Post: - 30th July 2007, 23:43
  3. Assembler and interrupt problem
    By milanche in forum mel PIC BASIC Pro
    Replies: 2
    Last Post: - 21st September 2006, 17:24
  4. Which assembler are you using?
    By picnaut in forum mel PIC BASIC Pro
    Replies: 1
    Last Post: - 1st November 2005, 20:34
  5. Assembler information
    By Demon in forum Documentation
    Replies: 1
    Last Post: - 25th February 2005, 14:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts