+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2004
    Posts
    87

    Default LCDIN not working?

    I am able to write to the display (20x4) but unable to read any characters out. I would like to use the ohm symbol and a few others. The last result has been an all dark segment in the first position. I have tried different addresses from the ASC11 and the Japanese fonts columns, same result. At one time I did get it to show some stray garbage spread out across the entire screen. The R/W line is directly connected to RD2 and is DEFINED properly. Using a 16F877. Code snip....


    PAUSE 100
    LCDIN $F4,[Ohm] 'LCD ohm character to var Ohm
    LCDOUT $FE,1 'Clear Screen
    LCDOUT $FE,2 'Return Home
    LCDOUT Ohm 'LCD show character ohm
    pause 5000

    This should put out the ohm symbol to the LCD?
    Any ideas? Thanks ,RC.

  2. #2
    Join Date
    Jul 2003
    Location
    Colorado Springs
    Posts
    4,935

    Default Re: LCDIN not working?

    You can only read CGRAM and DDRAM from an LCD.
    You can't read the CGROM character font tables.


    Hi, we are pleased to see that you are using our forum.

    We'd like you to become a member of our community. Membership is FREE, please REGISTER and view our forums without these annoying reminders!

    Once registered you may post on the forums, download from the file areas and use the WIKI without interruption.






    If all you want to do is display the ohm character, just LCDOUT $F4.
    DT

Members who have read this thread : 0

You do not have permission to view the list of names.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts