Compilation errors - strange


+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2009
    Posts
    2

    Default Compilation errors - strange

    Everything was going fine, compiling and programming various pics until this morning when I went to compile a PBP program for a chip that I was using the night before and got all these errors. I tried deleting parts of the program until I whittled it away to mere comments and still got the same errors. It seems like one of those things that I am just doing something stupid but cant see it. I tried compiling all kinds of programs that have been fine in the past but get more or less the same errors on all of the compiles. It seems like it is maybe a link to the library files that somehow went bad? I don't know. Would appreciate any suggestions. Attached is a screen shot of one of the programs and associated errors.

    Thanks,
    Gary
    Attached Images Attached Images  

  2. #2
    Join Date
    Nov 2003
    Location
    Wellton, U.S.A.
    Posts
    5,924

    Default

    Try making a directory "C:\TEST" and put your source code there. One source (project) per directory.
    Dave
    Always wear safety glasses while programming.

  3. #3
    Join Date
    Oct 2009
    Posts
    2

    Default Worked like a charm, but why?

    I never would have figured that out. I have been using the same directories for quite a while. All was well last night while I was compiling. Thanks much for your help.

    Gary

  4. #4
    Join Date
    Nov 2003
    Location
    Wellton, U.S.A.
    Posts
    5,924

    Default

    Not exactly sure why it works... I have an idea or two but...

    Having a separate directory helps me stay organized. Notes, drawings, source, etc for a project are all in one place for each project. Maybe it keeps PBP/MPASAM from getting confused??
    Dave
    Always wear safety glasses while programming.

Similar Threads

  1. Elapsed_Demo.bas compilation errors
    By Dick Ivers in forum mel PIC BASIC Pro
    Replies: 3
    Last Post: - 2nd March 2010, 00:44
  2. Replies: 3
    Last Post: - 1st July 2008, 22:07
  3. Picbasic Pro Demo assembly errors
    By mikeRho in forum mel PIC BASIC Pro
    Replies: 5
    Last Post: - 2nd January 2008, 07:41
  4. Microcode Studio Plus compile/assmebly errors
    By mikehagans in forum mel PIC BASIC Pro
    Replies: 5
    Last Post: - 18th February 2006, 22:31
  5. Strange ASM file
    By barkerben in forum General
    Replies: 2
    Last Post: - 29th November 2004, 19:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts