Search Results - MEL PICBASIC Forum


Search:

Type: Posts; User: LEDave; Keyword(s):

Page 1 of 4 1 2 3 4

Search: Search took 0.01 seconds.

  1. Replies
    3
    Views
    202

    Re: Neopixel (WS2812B) Question/s

    Hi Richard

    Have spent sometime on the Neopixels tonight and managed (after tweaking the RESET time) to get them to reset. I can now run 3 lines of Green, Red, and Blue in a loop, so making some...
  2. Replies
    3
    Views
    202

    Re: Neopixel (WS2812B) Question/s

    Thanks for the reply Richard.

    So am I reading it right that when the led's have lit up, they are in the 'ready' condition to receive another run of data?

    Problem I'm having is when I run the...
  3. Replies
    3
    Views
    202

    Neopixel (WS2812B) Question/s

    I have a string of 8 Neopixels which I can light using a FOR/NEXT loop each cycle setting a pin HIGH/LOW to light the string (24 BYTES * 8 cycles total).

    So Question: After I've written all 8...
  4. Replies
    7
    Views
    614

    Re: Setting 8Mhz clock speed on PIC16F684

    Dave & Richard, thank you both for taking the time to reply, much appreciated.

    Dave
  5. Replies
    7
    Views
    614

    Re: Setting 8Mhz clock speed on PIC16F684

    Thanks again Richard.

    So as long as I use DEFINE OSC X, PB knows and compensates for the change still giving the correct timings PAUSE etc?

    David
  6. Replies
    7
    Views
    614

    Re: Setting 8Mhz clock speed on PIC16F684

    Just to add, I based my last post on this article: http:// melabs.com/resources/pbpmanual/7_0.htm

    But I may have misinterpreted it, in that I thought PAUSE 1000 with DEFINE OSC 4 internal OSC...
  7. Replies
    7
    Views
    614

    Re: Setting 8Mhz clock speed on PIC16F684

    Hi Richard, thanks for the reply.

    "what do you expect the result to be ?"

    I thought (and was hoping) that double the OSC speed from 4 to 8Mhz would drive the led's twice as fast, 10secs would...
  8. Replies
    7
    Views
    614

    Setting 8Mhz clock speed on PIC16F684

    Can someone kindly help me please?

    I am trying to make a PIC16F684 run at 8Mhz instead of the default 4Mhz.

    Problem is, test led's just keeping flashing at 10 secs...

    I have MPASM ticked as...
  9. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Really pleased to say the project took a giant leap forward tonight. Have re-written some of the code to work with pull-down resistor now 0v = off, 5v = on.

    Tap a wire +5v to GPIO.0 ten times,...
  10. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi mackrackit.

    Here's the Tx and Rx code as is stands. The Tx program now transmits a data WORD on button press, not just the button press itself.

    Tx:


    @ __config _INTRC_OSC_NOCLKOUT &...
  11. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Will do mackrackit.



    Hi Demon. I hear what you're saying, makes good sense. I remember Henrik telling me that it didn't matter whether you sent Highbyte or Lowbyte first, your way kind of...
  12. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Just had a breakthrough with the project:)

    Having modified Bruce's code to make the timing loop run & transmit. Tx 'consistancy' was a problem. The data was only recieved about 3 in 5 times. So...
  13. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    It did / does. Bruce's code for the Tx - Rx on button press works a treat, it never misses a beat. The problem appears when we try and add in a time delay loop.

    Here's Bruce's original Rx code (a...
  14. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi Bert

    Well no the Tx side still has work to be done. The delay loop problem has / had to be overcome to get the project code to do what I want it to. The GPIO.3 / 4 pins will need to be set as...
  15. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    I think I've sent everyone on a wild Goose chase (sorry):o.

    Mackrackit's Tx code was working fine all along.

    I now think It's the Rx program that holds the key. The reason I think this is...
  16. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi Demon

    I hear what you're saying. By the time this project is finished a lot of changes will have been made to the set-up.

    This is my first excursion into RF, with Tx - Rx programs that...
  17. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi mackrackit / All

    In Bruce's oringinal code, the rfpic (if no buttons are pressed) goes to SLEEP until a button is pressed then Encodes & Tx's straight away.

    It seemed to me the data Tx is...
  18. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Two versions to look at really Demon. I've posted two, it might help you see 'something' because although very similar, what they both do is subtley different things.

    The first one does this on...
  19. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    I'm using a power supply set at 4.66v.

    For some reason my attachments are appearing here 'inline' rather than at the page bottom, sorry.

    The comment about dataask going high caught my eye....
  20. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    I moved the code.

    What happens is:

    1/ If a button is pressed and released RFEN briefly flashes after the 5sec delay (no data is Tx'd).

    2/ If a button is continually pressed, nothing...
  21. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi cncmachineguy, I suspect timing has a lot to do with it (although I don't kow enough to say or point to why).

    Plenty of head scratching going on here.



    Yes, pauses for too long are...
  22. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi mackrackit

    I reloaded your code and the rfpic worked exactly as before, namely:

    The RFEN led lit for five seconds immediately either button was pressed but nothing was transmitted.

    ...
  23. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Made a mistake, please ignore this post,Dave.
  24. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    A breakthrough, I think....

    I moved the delay loop to run right after the IOC from @SLEEP. So what happens now is if GPIO.3/4 are held down, after 5sec delay data is Tx'd. If GPIO.3/4 are pressed...
  25. Replies
    928
    Views
    104,100

    Re: 12f675_fuse_about_to_blow!

    Hi mackrackit



    I did and I am still hoping to get it working: Post #893 above has ON INTERRUPT -DISABLE-ENABLE-RESUME in the code.

    Thanks for the TX program, I had to change:

    ...
Results 1 to 25 of 100
Page 1 of 4 1 2 3 4