Search:

Type: Posts; User: fratello; Keyword(s):

Page 1 of 4 1 2 3 4

Search: Search took 0.02 seconds.

  1. Replies
    13
    Views
    4,490

    Re: Input problems with 12F629?

    See this post : http://www.picbasic.co.uk/forum/showthread.php?t=1426&p=7072#post7072
    Maybe is useful !
  2. Replies
    6
    Views
    1,271

    Re: Again about array

    Yes, I use only 8 value.
    Thank you, all !
  3. Replies
    6
    Views
    1,271

    Re: Again about array

    Thank you verry much ! Works fine !
    I really appreciate it !
    ...and how to continue to second line of LCD ? There is no room for ten values on the first line ...
    Something like this ?

    LCDOUT...
  4. Replies
    6
    Views
    1,271

    Again about array

    Hi !
    I tried to read 10 samples of ADC values and sending to LCD display.

    DataW var word[10]
    i var byte


    main:
    for i=0 to 9
    ADCON0.1 = 1 ' Start conversion
  5. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Nope :) ! No change !
  6. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Thanks ....but I have already FULL decoupling...8538
  7. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    @tumbleweed : I don't understand what you mean ...
    @Mark's : It's impossible another approach ! The steering wheel commands don't allow ...
  8. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Despite all the modification, the "adapter" still work foolish ... No change to the initial code.
    ...
    "You say it worked fine until you put it into the vehicle. That should be a clue. "
    I think so...
  9. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Thanks for suport !
    @Tumbleweed : I used code from this post : http://www.picbasic.co.uk/forum/showthread.php?t=18495&p=123207#post123207
    @Jerson : Tried already ...no improvement !

    @ __config...
  10. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Thanks again !
    I have 100 nF capacitors near to power pins of PIC and MCP ... I use a Sony player for tests ; I don't have a serial display.
    As I said, my previous attempts (using PIC ADC) worked...
  11. Replies
    16
    Views
    2,285

    Re: MCP3201 problems

    Thanks for reply !
    I attached iin my first post the Proteus simulation and the pbp file ... I used 16F676 for "driving" six resistors (for Sony players); MCP3201 must read the valiues of the...
  12. Replies
    16
    Views
    2,285

    MCP3201 problems

    Hi ! I tried to make an adapter for steering wheel audio controls, based on MCP3201 (since my previous tries based on PIC ADC failed, being inaccurate) . In Proteus it works fine, but in "real world"...
  13. Replies
    15
    Views
    4,370

    Re: Error Compiling with PbP 3

    Don't know how...but solved. Thanks !
    8418
  14. Replies
    15
    Views
    4,370

    Re: Error Compiling with PbP 3

    Sorry, is 16F628A !
    8417
  15. Replies
    15
    Views
    4,370

    Re: Error Compiling with PbP 3

    No change !
    8416


    @ ERRORLEVEL -306
    #CONFIG
    __CONFIG _XT_OSC & _WDT_OFF & _PWRTE_ON & _MCLRE_ON & _BODEN_ON & _LVP_OFF & _CP_ON
    #ENDCONFIG

    ;INCLUDE "D:\PBP\ALLDIGITAL.PBP"
  16. Replies
    15
    Views
    4,370

    Re: Error Compiling with PbP 3

    Thanks for fast reply !
    But ... I don't understand what I do wrong :( ...
    I wrote :

    Exactly like in post #3.
    8415
  17. Replies
    15
    Views
    4,370

    Re: Error Compiling with PbP 3

    Hi !
    For me the solution don't work ? Any others sugestions ? Thanks !
    8414
  18. Replies
    21
    Views
    3,253

    Re: reading I/O state of pic12f675...

    Read here : http://www.microchip.com/forums/tm.aspx?m=303686&mpage=2&key=&
    It's about 12F629 but ...maybe is useful !
  19. Replies
    21
    Views
    3,253

    Re: reading I/O state of pic12f675...

    See link : http://mini12f.blogspot.ro/2013/05/proyecto-recuperar-valor-configuracion.html
    Regards !
  20. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    I see ... Thank you !
    LE : Please, can share asm & hex file, as results of PBP3 compiled ?
  21. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    Thanks for reply ! Proteus work fine even without resistor for LED ... I wonder if my "adaptations" of code are corect.
  22. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    @Mr.Richard : Tried to figure out how your soft work ... But in Proteus nothing happens.
    I do something wrong ? I "addapted" the "elseif" command, since is not present in PBP 2.6 (?).
    Thanks in...
  23. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    Thank you all for support !
    Very interesting suggestions and points-of-view ...
    @Richard :
    Of course !!!
  24. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    Already tried ... it's act like I always press SHORT !
  25. Replies
    37
    Views
    11,952

    Re: Long / short press button...but reading ADC

    The schematic is working into "hard" environment ... I tried different variants before this. THIS is the only way to have accurate readings of ADC.
Results 1 to 25 of 100
Page 1 of 4 1 2 3 4