PDA

View Full Version : PBP3 stopped generating hex files



keithv
- 25th November 2014, 01:28
I was using PBP3 and a 3rd party programmer just fine. Then I got labX1. I was playing around with that. Everything was working fine including the U2 programmer. I only used it once.

Next time I launched microcode studio, everything seemed to work fine. I made some changes to an existing program. The program saved and seemed to compile fine, but when I launched my 3rd party programmer, there was no hex file to be found.

I plugged the labX1 and U2 programmer back and tried it with that. No those don't work either. The program saves and the compiler status bar says everything is OK, but there is no hex file. Also, if I click on compile and program button, it will not launch the programmer either.

muddy0409
- 25th November 2014, 03:17
Far from being an expert in this stuff, the same thing happened to me a while ago.
The solution was the .HEX file saved to a different location (somehow) than normal, so the programmer couldn't find it.
That MAY be the problem, but no promises.

keithv
- 25th November 2014, 21:33
Did some research in other forums and found out the problem. You can only have 1 dot in your file name. I had named the file suchandsuchRev1.1.pbp and it wouldn't generate the hex file. Changed it to suchandsuchRev2.pbp and it worked as usual.

muddy0409
- 26th November 2014, 00:54
Well, always nice for there to be a simple explanation.
I will file that one away for future reference.