View Full Version : iChip's Nano LanReach configuring problem

- 9th September 2014, 20:42
Long time no see guys. At least army life is over!!

I've made a pic command line editor at pbp so i can communicate with my nano lanreach module(pc-->mcu-->module). It's identical to nano Lan module except some extras features. I'm facing problem with the read and write to the module. Is here anyone that used it in the past??? I can't understand the communication sequence :/

i forgot to mention*** I use Pic18F26K22 at 64MHz clocked and im using both USART peripherals (tried baud rate 9600 & 2400 and the result was the same) . The concept is that i want to create a website with some variables being updated in it.

- 10th September 2014, 03:17
I have not used the module for a website, but this thread should give you a feel for the syntax.
If you have not changed the baud rate it will be 38400 by default.

- 11th September 2014, 13:03
Hey Dave, thank you for your respond. I was able to communicate with my Nano LanReach i just set the AutoBaudRate and everything worked out.
Also i did study the http://www.picbasic.co.uk/forum/showthread.php?t=14912 of your example code. I've read the whole conversation with john ellis. Anyway, i want now to use my NanoLanReach as a webserver but i am completly confused. I dont know where and how to write HTML code to upload a simple messaging website , like :


-Witch protocol shall i use FTP or HTTP ?? I'm trying to find something in the Programmers Manual but i only did activate the internal webserver and i got the local IP as a response.

-Do i have to do port forwarding so i get my device to the outter world ?

- 12th September 2014, 15:37

I can not help much for the web server problem, but here is what I know.
First you have to enable the web server with

Then you can access the module over your lan with, for example
and there is a pre-built page at
where some of the configs can be changed and files uploaded to the module if you have the
password set

["AT+iRPG=password",$d ,$a] ' SETS REMOTE PASSWORD
The default port is 80 for the server, the last I checked the port could not be changed. So depending on the capabilities of your router and other devices on your net work (maybe a real server on port 80) you may find it challenging to connect from the WAN.

If you go here
You will find a config utility that will help in building and uploading web pages to the module.

That is all I got.

- 13th September 2014, 10:21
Thank you a lot Dave. I will try to set up this server and bring it to the outter world !!! I'll let you know what happens with my progress in an other topick.

Best regards, Kostas

- 13th September 2014, 17:17
By the way Dave,
doesn't this command "+iWEBP" change the webservers PORT ??
If you read at page 71 of Programmer's manual at the command "+iWWW" it says:

1, 2 or 3 browser connections can connect simultaneously to iChip’s TCP port 80, or as defined in the WEBP parameter, implementing HTTP protocol.

And continues with the command.....

+iWEBP – Web Port
Sets the port number for iChip’s Web services. Remote browsers will need to open sockets to this port for Web services.
Command Options:
Use the well known port numbers: (80) for HTTP service or (443) for HTTPS service.
Use port number <port> for HTTP or HTTPS service.
0 (use well known ports)
Result Code:
If port is a legal value
Returns current port number followed by I/OK.
Returns the message “0-65535” followed by I/OK.

Best regards, Kostas!!

- 14th September 2014, 11:37
They made an update, WOOHOO!!!
It has been awhile since I set one of these up, I guess I need to update manuals and firmware.
Thanks for the information!!!!!

- 14th September 2014, 22:13
I am happy being able to help !! Now i get back in studying server, transfer protocols, Nat system and other stuff :P:P